何でもありの備忘録
by takahiro_komiya
カテゴリ
以前の記事
2017年 09月
2017年 08月
2017年 07月
2017年 06月
2017年 05月
2017年 04月
2017年 03月
2017年 02月
2017年 01月
2016年 12月
2016年 11月
2016年 10月
2016年 09月
2016年 08月
2016年 07月
2016年 06月
2016年 05月
2016年 04月
2016年 03月
2016年 02月
2016年 01月
2015年 12月
2015年 11月
2015年 10月
2015年 09月
2015年 08月
2015年 07月
2015年 06月
2015年 05月
2015年 04月
2015年 03月
2015年 02月
2015年 01月
2014年 12月
2014年 11月
2014年 10月
2014年 09月
2014年 08月
2014年 07月
2014年 06月
2014年 05月
2014年 04月
2014年 03月
2014年 02月
2014年 01月
2013年 12月
2013年 11月
2013年 10月
2013年 09月
2013年 08月
2013年 07月
2013年 06月
2013年 05月
2013年 04月
2013年 03月
2013年 02月
2013年 01月
2012年 12月
2012年 11月
2012年 10月
2012年 09月
2012年 08月
2012年 07月
2012年 06月
2012年 05月
2012年 04月
2012年 03月
2012年 02月
2012年 01月
2011年 12月
2011年 11月
2011年 10月
2011年 09月
2011年 08月
2011年 07月
2011年 06月
2011年 05月
2011年 04月
2011年 03月
2011年 02月
2011年 01月
2010年 12月
2010年 11月
2010年 10月
2010年 09月
2010年 08月
2010年 07月
2010年 06月
2010年 05月
2010年 04月
2010年 03月
2010年 02月
2010年 01月
2009年 12月
2009年 11月
2009年 10月
2009年 09月
2009年 08月
2009年 07月
2009年 06月
2009年 05月
2009年 04月
2009年 03月
2009年 02月
2009年 01月
2008年 12月
2008年 11月
2008年 10月
2008年 09月
2008年 08月
2008年 07月
2008年 06月
2008年 05月
2008年 04月
2008年 03月
2008年 02月
2008年 01月
2007年 12月
2007年 11月
2007年 10月
2007年 09月
2007年 08月
2007年 07月
2007年 06月
2007年 05月
2007年 04月
2007年 03月
2007年 02月
2007年 01月
2006年 12月
2006年 11月
2006年 10月
2006年 09月
2006年 08月
2006年 07月
2006年 06月
2006年 05月
2006年 04月
2006年 03月
2006年 02月
2006年 01月
2005年 12月
2005年 11月
2005年 10月
2005年 09月
2005年 08月
2005年 07月
2005年 06月
2005年 05月
2005年 04月
2005年 02月
2005年 01月
2004年 12月
2004年 11月
<   2011年 01月 ( 18 )   > この月の画像一覧
Virtual Cluster Switching の動き方
Virtual Cluster Switching 技術は TRILL フレームを使用する。しかし、今日時点では TRILL そのものではない。以前からここでも書いているが、FC ファブリックサービスを使用している。

VCS は FC スイッチそのものではないが、FC スイッチの動作がわかると VCS の動作もよくわかる。ということで、参考資料はこれ

- 7 Fabric Configuration
- 8 Fabric Shortest Path First
- 9-3 Distributed Name Server

はかなり役立つ。
by takahiro_komiya | 2011-01-28 12:21 | Ethernet
Userspace Switch OnVMware
MLに流れているのを見ていまさら知った。

http://www.openflowswitch.org/wk/index.php/UserspaceSwitch_OnVMware
by takahiro_komiya | 2011-01-26 14:46 | Ethernet
Open Virtual Compute Block デモ
なんのことはない、Brocade/DELL/VMware による ソリューションパッケージです。
by takahiro_komiya | 2011-01-24 22:56 | その他 technology
Paas/SaaS ではなく自社 IaaS に傾倒するメーカーと、RAD ツールを使わない SIer さん
アプリを書くのに言語を選ぶのはナンセンスだけど、フレームワークなら別。別に下の環境をサービスプロバイダーが提供してくれるのならソッチの方が楽じゃない&スモールスタートできるし、という友人のコメントはよく理解できる。Server App-V なんかも、自分で VM Role 使って管理するメリットがあるのであろうか。Worker Role 使って、Azure を使い切ることに意味があると思うのだが。

でも、とあるメーカーさんと話をすると、Azure を使うのはメーカーとしての差別化にならないとのこと。そりゃそうだが、ユーザーはそこを期待しているわけではないのだが、たぶん。

このセンテンスを聞いて思い出したのが、Genexus や Sapiens の話。某 SIer さんはこの手のツールは提案しないし、使いもしないとのこと。たしかにユーザーが Genexus 使ったら、商売あがったりなんだろうなぁ。

なんだか似ているなぁ。

その点、この記事はとてもいい。
by takahiro_komiya | 2011-01-24 22:42 | その他 technology
AMPP のその他の port-profile
先日のこの書き込みでは VLAN プロファイルだけ入った port-profile の例を書いた。

AMPP ではそれ以外に QoS profile, ACL profile, FCoE profile (NOSv2.0.0では同時には使えない)などがある。これらのポートプロファイルもひとつの port-profile の中で設定する。

例えばこんな感じ

port-profile VDXdemoVMVLANprofile1
vlan-profile
switchport
switchport mode access
switchport access vlan 1
!
security-profile
mac access-group VDXdemoACL in
!
 qos-profile
cee default
qos cos 7
qos trust cos
qos cos-mutation vm1-cos2cos-map
qos cos-traffic-class vm1-cos2traffic-map
!


でもって、cos-mutation, cos-traffic-class などを設定しておけば(こっちを先に設定しておく必要あり)、ばっちり。


VDX2(config)#qos map cos-mutation vm1-cos2cos-map 0 1 2 3 5 4 6 7
VDX2(config)#qos map cos-traffic-class vm1-cos2traffic-map 1 0 2 3 4 5 6 7

by takahiro_komiya | 2011-01-22 10:43 | Ethernet
AMPP のいいところ
VDXのAMPPについてはかいたが、いいところについて書いていなかった。

スイッチが自律的にポートプロファイルを強制するため、ハイパーバイザに依存しない。これは非常に強力な利点だ。

Distributed Configuration Management が実装されたら、論理筐体の利点もくわわり更に便利。

一方、いまのところの弱いところは、前の投稿でも書いたけど、サーバ管理者の設定したMACをネットワーク管理者に連携するかということろ。EVB標準ができて、ハイパーバイザ側が連携機能を実装してくれないかな。
by takahiro_komiya | 2011-01-20 23:36 | Ethernet
NTTDATA Innocation Conference 2011のセッション「クラウド時代のネットワーク仮想化技術の現状と動向」
掲題のイベントがあることを今日知った。「クラウド時代のネットワーク仮想化技術の現状と同行」という講演に期待。
by takahiro_komiya | 2011-01-20 15:50 | IP networking
VDX の Automatic Migration of Port-Profile(AMPP)
AMPP とは何かというと、特定のポート(MAC)に対して決められた属性(ACL, VLAN, QoS, そのうち FCoEも?)をスイッチの特定ポートから別のスイッチポートに対して自動的に移動させる技術だ。

あんまりないけど、サーバのポートを別のポートに勝手に変えても自動的にポリシーが追従してくれるという機能だ。イメージで言うと FC の port WWN による zoning と似ている(というか同じ)。ファブリック内のどのFCスイッチにつないでも勝手に Zoning を enforce してくれるからだ。仮想マシンは物理マシン上を移動するので特に問題。そこで Edge Virtual Bridging では Virtual Station Interface Discovery and Configuration Protocol という仕組みを考えて、この問題に対処しようとしている。

Brocade VDX では VCS の Ethernet Fabric により、最初から MAC, Port-Profile DB は全体で同期しているので、ポイントは「仮想マシンの管理者」と「ネットワーク管理者」の間の「Port Profile」「適用される MAC」の連携部分。しかし、ここだけは標準がないため、現在は手作業。

b0068870_18275142.jpg



(a) port profile はこんな感じ(一番簡単な VLAN profile)
port-profile VDXdemoVMVLANprofile1
vlan-profile
switchport
switchport mode access
switchport access vlan 1
!
port-profile VDXdemoVMVLANprofile2
vlan-profile
switchport
switchport mode access
switchport access vlan 2
!

(b)profile と MAC の紐付け(ここが自動化されたらいいなぁ)
port-profile VDXdemoVMVLANprofile1 activate
port-profile VDXdemoVMVLANprofile1 static 0050.563f.0001
port-profile VDXdemoVMVLANprofile1 static 0050.563f.0002
port-profile VDXdemoVMVLANprofile2 activate
port-profile VDXdemoVMVLANprofile2 static 0050.563f.0003

(b)profile を使用するインターフェースには port-profile-port を指定
interface TenGigabitEthernet 1/0/5
fabric isl enable
fabric trunk enable
port-profile-port <-- ここ
no shutdown

(c)トラフィックが流れると MAC にプロファイルが適用される
VDX1# show port-profile status associated
Port-Profile PPID Activated Associated MAC Interface
VDXdemoVMVLANprofile1 1 Yes 0050.563f.0001 Te 1/0/5
0050.563f.0002 Te 2/0/5
VDXdemoVMVLANprofile2 2 Yes 0050.563f.0003 None




b0068870_1828070.jpg



とまぁ、こんな感じで結構普通に動きます(上でも書いたけど WWN zoning と同じ発想だし)。
by takahiro_komiya | 2011-01-19 18:43 | Ethernet
次世代のICL
今日はやばい。咳がとまらないのと、微妙に7度の熱なので休んで病院にきている。この書き込みは、玄関で書いているので、電波の件は大丈夫でしょう。

ところで、次の世代の Inter Chassis Link は、いままでの copper ではなく光になる。一枚の Core Routing Blade あたり、16ポートある。したがって、16 x 64G = 1Tbps である。いつもどおり、CRは2枚あるので、2Tbpsだ。full duplex を考慮すると、4Tbps。まぁ、ここまでの構成は日本にはないけど。
by takahiro_komiya | 2011-01-18 09:55 | ファイバチャネル
まだ着てないけど、くるー。4x16G QSFP
16GFC 世代で Inter-Chassis Link は QSFP になる。つまり 4 x 16 =64GFC だ。
b0068870_1521215.jpg


この技術の個人的なアピールポイント。

14.025Gbps というスピード
もちろん、100GbE の 25Gbps のもすごいけど、キャリア向けではなく、enterprise 向けな点。でも BASE-KR に 14G は乗らない。
・Frame-based Trunking と一緒に使うことで事実上 64GFC
ブロケードの ISL Trunking と一緒に使えば、64GFC です。
by takahiro_komiya | 2011-01-17 15:12 | ファイバチャネル